I suggest you ...

The site doesn't remember my language preference

"English (United States)" is my second preferred language in my web browser —the first one is "Spanish (Argentina)"—, but the site always load French as default, no matter my selection.

1 vote
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
KNTRO shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base